Letter 14
Home INDEX

 

Isuzu Trek Owners Infoletter #14, August 2004

Editor's note: You will notice that the contributor's email addresses have been altered by changing the "@" to "at". This was done because it should keep web-crawling spammers from picking up the email addresses to add to their lists.

Firewall fastenings again

Linda (lindadahle at bdumail.com)writes

I have been distracted from emailing by sightseeing and taking care of day to day things while on the road.

I had the front body of my 94 Trek checked while in Phoenix. I had noticed a good deal of movement between the dash and the front sidewalls. The mechanic could see where things were rubbing with at least one inch movement. In order to try and prevent future damage, the mechanic built a frame made of angle iron forward from the step up. He attached the angle iron to the frame at the step up and ran it at the rivet line around the front of the body with several cross pieces for bracing. He drilled out the old rivets and put in new ones which go through the angle iron. The cost to me was about $600.

I saw and felt the difference immediately. And just as quickly the repair began to slowly fail and after 30 days, the bounce was back and 6 or so rivets had pulled out on each side. The next RV repair place installed steel core rivets, the others were aluminum core. I immediately noticed the difference again. I will let you know if these last.

Thanks, Linda

Furnace and storage compartment leaks

Linda Dahle also writes:

I just learned something new about my furnace.

If I have the inverter on I do not have enough power for the furnace (fan will run but not fast enough to trigger the igniter). Even if I have the generator on, and especially on battery. I think it is due to the added pull of my electric mattress pad etc. Well a little power management on my part should solve the problem.

I really enjoyed the letters. I checked and the rear light was letting water in. Thanks

I have one storage bay, just left of entry door, that has water in it always. I have blocked the vent, checked the door, any ideas?

Editor's Note: I suggested one of those window curbs that deflects water be installed just above the compartment door as the only water that gets in mine comes running down the side from above due to rain or air conditioner condensate. Any other ideas?

I-Trek Transmission

Robert Plante (robert.plante2 at sympatico.ca) writes:

Here's a story for your infoletter....by the way the letters are really

instructive and may eventually help us when needed. Last December I bought a Safari Trek 1994 2600 twin bed.

We live in Quebec Canada and the Trek as located in Dallas Texas; At the beginning of December I went by plane to Dallas and brought the rek home with no problem except for the oil filter. If you ever decide to hange it by yourself don't forget to tighten it enough by using the appropriate tool. Don't use just your hand because the oil filter won't be tight enough and if the oil filter is lost while on the road that could be a disaster.

At the end of January 2004 we left Montreal, Quebec for vacation.with no problem at all except on our way back home. One morning I started the engine with no problem but the transmission refusednto shift from the first to the second gear. At that moment I remembered the info letters which said to stop the engine for 5 to 10 minutes and then everything must be OK. Effectively that worked but the tranny had difficulties shifting from the 4th to overdrive. We stopped one more time and the morning after same thing happened. Once I was home I finally found the problem with the help of my mechanic and the help of some member of Trek Talk. I just changed the transmission oil and transmission oil filter. Now everything is perfect. Trek owners mustn't forget to have the tranny oil changed regularly. Mine had around 60K on it at that time and believe me that was way too much.

Good info about the I-Trek cruise control!

Editor's note: I always look forward to reading what Ken Harmon (kencathyha at aol.com) writes about his Trek because he does such a good job of troubleshooting, then describing it. Here is his cruise control fix:

Dale: the following is some information on what I did to repair my cruise

control.

I started troubleshooting the Acme cruise control by locating all the components. First I removed the forward dash cover to gain access to the back of the instrument panel. Following the push-pull control up from the servo in the engine compartment, I found that it penetrates the top of the firewall close to the speedometer cable and then loops up and over 180 degrees behind the dash. The control goes straight down to the throttle mechanism above the

accelerator pedal. The cruise control wiring harness follows close to the same route and is bundled up under the dash to the left of the steering column. My four-pin connector was included in this bundle. The cruise control brake light relay is attached to the left side of the vertical member ahead of the steering column using a tie-wrap. The power lead for the cruise control comes over from the circuit breaker panel to an old-style glass fuse encased in a small black plastic clamshell housing. On my coach the fuse is behind the dash and just to the right of where the cruise control push-pull loops over to the throttle. Using the information in the Acme literature I tested all the circuits using a volt-ohm meter. The tests for the slide switch and set button all checked good. The test for a clicking sound at the servo was good when the two-pin

plug was removed and then reinstalled. I tested for voltage at the single-pin connector and conducted the brake pedal test. No problems could be identified. I cleaned and checked the brake light bulbs to be sure the filaments were providing a good ground circuit for the brake light relay. To further test the system I fabricated a test harness that I could splice between the steering column switch harness and the under-dash harness at the four-pin connector. The test harness was equipped with pigtail wires to facilitate using a test lamp as called for in the Acme troubleshooting instructions. Retesting the circuits with the lamp disclosed a problem with the single blue wire (blue according to ACME but black on my coach) at the servo. The test bulb did not light. Following the blue (black) wire back to the brake light relay, I found 12 volts were going into the relay and only 3 volts were showing at the blue wire coming out of the relay.

Using the information in the Isuzu Trek Newsletter I contacted ACME in Kansas City (800-422-6322 or 913-371-5373). They referred me to Goshen, Indiana, (800-552-2263 or 574-534-1516) to talk to Terry about my test results. He seemed to be knowledgeable on the product but it has been several years since he was involved in troubleshooting. First he recommended checking the ground connections. Then he suggested driving the vehicle to 45 mph and then moving the slide switch to the left and holding it in the "Resume" position. If the

cruise control eventually comes on and holds or gains speed, it indicates that the brake light relay is bad. This test also verifies that the servo, the push-pull, and the rest of the connections are good. My cruise control worked, indicating that the relay was bad. I called the parts department in Kansas City and had a new relay shipped.

Now the problem: I installed the new relay, ran the bulb test again on the blue (black) wire, and found the relay did not work. I called the factory and they told me to roadtest the unit. It did not work. I tried it again the next day and it did not work. Finally I just gave up on solving the problem prior to our next trip. Two days later I just happened to try it one more time and it worked.The cruise control worked okay for three months and then it failed again. I called Acme and they sent a new brake light relay. This time I bench-tested it prior to installation and it did not work properly. One thing I did not like about the original Acme relay setup was that the relay was "on" all the time when it was installed. The brake light circuit on my Trek is hot all the time, key on or off. Because the circuit is hot all the time, the Acme relay is

activated all the time, even when the coach is not in use. It also causes a slight drain on the electrical system. I decided to replace the Acme electronic unit with a simple electromechanical relay from Radio Shack. Since I was reworking the system I added a second relay ahead of the brake light relay to shut off all the power to the cruise control when the slide switch is in the "off" position. I added an LED to this circuit to tell me when the unit is on and that all the circuits are working properly.

Now I knew the brake light relay was working properly but, as I suspected, there were two problems in the cruise control system. After talking with Terry again I removed the servo and cleaned the three contacts inside the unit. Before reinstalling the unit I cleaned the three wire connection posts on the outside of the unit and installed a second ground wire just to make sure the ground was good. There was no improvement.Terry agreed it was time for a servo replacement. The new servo was about 40% cheaper when purchased out of Indiana versus the quote from Kansas City.The cruise control now works much better than it ever did before. It holds speed close to +/- 1 mph. and will work all the way down to near 25 mph. It still drops about 5 mph from the initial set point but tapping the "Set" button brings it up to speed.

Grease

Tom (tjgriep at copper.net) says:

Hi Dale, The only thing that comes to mind is about the use of High pressure grease, not just plain grease. The Trek owners manual calls for High pressure grease. The first High pressure grease I found was Slick 50 grease, it's pink. This also helps in doing a proper job of greasing your Trek. You need lots of rags too, so that you can catch the old grease coming out until you see nothing but clean new grease. This is the only way to properly flush out any dirt that will cause wear. I bought an air grease gun ($12.00) which really helps you can use one hand to hold the hose on the zerk and trigger with the other. After doing a proper greasing the next greasing will take less time & grease.

Editor's note: It is true that the manual says "use multi purpose grease with high temperature, good quality, Lithium soap, extreme pressure grease". My survey of a few 'experts' indicates that Trek owners have a choice. Using the high pressure grease is good, if you are doing the job yourself, or if you don't do your own oil change and lube jobs, you could furnish a grease gun loaded with the high pressure grease to the guy in the pit, or you can just use the standard stuff, as most of us have been doing for some time. Just use it often and move enough grease through to flush out the road dirt, as Tom and the experts said.

Fuel Contamination

Dutch (dutch98221 at verizon.net) writes:

I will tell you about a screw up I made. While refueling in the sticks of New Mexico after a long day,I (by mistake) filled the fuel tank about half full with gas! (at a truck stop) I asked the local mechanic what to do. He said to add one quart of 30 wt oil and fill it on up with diesel,which I did,

I got about 1-2 miles down the highway and the engine suddenly quit!

Luckily I always carry two 5 gallon cans of diesel as I only have one fuel tank. I drained the tank(from the large bottom plug). I then dumped in the 10 gal. of diesel, emptied the primary and secondary fuel filters, ran the starter and bled fuel till I got good diesel. Engine started and ran fine

On that trip we went to Key West and up the east coast and across New York, to Salt Lake City and back to Washingtom State- About 8000 miles after the diesel escapade and everything is still running fine. I recently replaced all the belts and hoses, flushed the cooling system and added new antifreeze. The trek is now almost ten years old and has 62,000 miles on it-running like a top!!

Editor's note: Now we know that oil plus gasoline does not diesel fuel make, and that if we make that same mistake, we are in for a lot of work! Also considering the potential damage to the injector pump, it's a good mistake to be careful not to make. Thanks for reminding us, Dutch!

Fuel tank line problem revisited, with a quick fix

Jim Goedde (jimgoedde at msn.com) writes:

Our latest Isuzu Trek problem turned out to be a cracked fuel pickup tube in the fuel tank. Apparently this is a fairly common problem. It would run ok at low speed but lose power on the freeway. I cleaned the water separator and replaced the fuel filter with no improvement in performance. Using the hand pump and bleeder valve on the fuel pump, I still could not quite get all of the air out of the system. We used a long piece of fuel hose attached to the inlet side of the water separator and inserted into the fuel tank to diagnose the problem.

The tank has a 45 degree elbow near the bottom. We removed the pipe plug from the elbow and replaced it with a male to female pipe reducer. This allowed us to install a 5/16" hose fitting into the reducer. This fix got us going again but, it is only temporary. If a rock or other road debris should strike the hose or fitting it could drain the fuel tank. I have some ideas for a permanent repair but just haven't done it yet.

Editor's note: This one is hard to diagnose, so keep this one in mind if you experience a partial power loss. I recall another I-Trek owner reported this same problem. Jim has offered a good temporary fix. We will look forward to his ideas on a permanent fix in the next letter.

Happy Trekking from all of our contributors. If reading this has helped you remember something about your Trek, please send it to me NOW!, while you are thinking about it.

Dale